Go Back   Technibble Forums > Technical Discussions > Networking

  Technibble Sponsor

Reply
 
Thread Tools Display Modes
  #1  
Old 03-20-2012, 03:38 PM
evlfred's Avatar
evlfred evlfred is offline
 
Join Date: Nov 2008
Posts: 53
evlfred is an unknown quantity at this point
Question Windows 7 Pro folder sharing to Macs stops working

anyone else gotten this? I have a company that we are sharing a folder off a Windows 7 Pro machine for documents. Everyone can connect fine (the folder is shared and secured via user accounts) when the machine boots up. After a while (1-5 days) the Macs can no longer access the share with a message of "there was a problem connecting to the server ____, check the server name or ip address" I've tried every setting I can to fix it, but until the host is rebooted the Macs can't connect.
Reply With Quote
  #2  
Old 03-20-2012, 05:15 PM
Encrypted Existence Encrypted Existence is offline
 
Join Date: Aug 2011
Posts: 1,239
Encrypted Existence is on a distinguished road
Default

Quote:
Originally Posted by evlfred View Post
anyone else gotten this? I have a company that we are sharing a folder off a Windows 7 Pro machine for documents. Everyone can connect fine (the folder is shared and secured via user accounts) when the machine boots up. After a while (1-5 days) the Macs can no longer access the share with a message of "there was a problem connecting to the server ____, check the server name or ip address" I've tried every setting I can to fix it, but until the host is rebooted the Macs can't connect.
Does the Windows 7 Pro machine (server) have a static IP address? Is it possible that the "server" is receiving a different IP address from the DHCP server after 1-5 days and that is what is breaking the connection? Also, check the event log on the "server" to see what you can find if you haven't done so already.
Reply With Quote
  #3  
Old 06-19-2012, 07:08 PM
evlfred's Avatar
evlfred evlfred is offline
 
Join Date: Nov 2008
Posts: 53
evlfred is an unknown quantity at this point
Default

Just solved this and wanted to record the information here. There are some registry changes you can make to allow for more network cache that corrects the issue, also works with windows XP having connectivity issues.

The solution below is pasted site I found.


Apparently you need to tell Windows that you want to use the machine as a file server and that it should allocate resources accordingly. Set the following registry key to ’1′:

HKLM\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management\LargeSystemCache

and set the following registry key to ’3′:

HKLM\SYSTEM\CurrentControlSet\Services\LanmanServe r\Parameters\Size

After making these changes and restarting, I haven’t seen this issue arise again. Fixed!
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 10:03 AM.


Powered by vBulletin®
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Technibble.com is based out of MELBOURNE, AUSTRALIA.