PDA

View Full Version : RDP Port forwarding troubleshooting


htsource
09-04-2009, 02:43 AM
Trying to troubleshoot RDP issue where I can't remote in from outside the network. It used to work but recently I got a new DLink DIR655 router and they also received a new Bell modem.

I setup port forwarding from DIR655 which I confirmed all settings are correct. Within the internal network, I can connect to the server using RDP. I wonder if it's the modem that's blocking the connection, but it's just a modem, not a router+modem.

Any suggestions where to go from here? Thanks for your help.

Cue
09-04-2009, 02:50 AM
If you cant connect the old modem again and try.

Then I think your only option it to connect a computer directly to the modem bypassing the router and see if that works.

You can also do a online port scan to see if the port is open.
I use this one,, as I like it.
http://www.t1shopper.com/tools/port-scanner/

htsource
09-04-2009, 03:00 AM
Thank you very much for your response, I just tried using the port scanner and 3389 is not available. I even enabled remote management of the router and still nothing. Good idea to go direct to the modem, will give that a try.

Thanks again.

LunchBox
09-04-2009, 03:15 AM
is port 3389 is not open then to me that would indicate that the router is not configured correctly. The modem should be bridge so that the router takes care of the login in

htsource
09-04-2009, 03:17 AM
Port 3389 is confirmed working internal network as I can RDP from another desktop to the server no problem. Port forwarding is setup on the DLink, as well I also enabled remote management of the DLink router, however, port 8080 is still not responding so nothing works.

drewster
09-04-2009, 07:43 AM
Could you post a screenshot of what your port forwarding settings look like on your router?

Cue
09-04-2009, 08:57 AM
If nothing answered when you connected the computer directly to the modem (and you put the right IP address on the computer) it could be the ISP not giving you a valid/legal Internet address (public ip).

Call them up and ask if you have a static IP address and its not shared (NATed).

htsource
09-06-2009, 03:00 AM
I'll be going back onsite to check it out, thank you for all your suggestions.