PDA

View Full Version : Netgear router & 20mb = 50% speed loss!


MM PC Solutions
06-23-2009, 10:45 AM
I just shot round to my sister as she was complaining that her new router didn't impress her all that much with it's speed.

The router: Netgear wgr614v7 (updated to the latest firmware)
Connection: Virgin 20mb (cable)
Modem: Ambit E08C013:00

The modem, router & her pc plus one other are all connected by RJ45's, no wireless.

Both PC's (XP & Vista) are virus/spyware free.

When connected straight to the modem the speed is good. As soon as the router comes into play the speed drops by half.

I have disabled both OS's standard firewall (no third party firewall installed) but this did not improve the situation.

Things I adjusted within the router control panel:
NAT from strict to open, disabled upnp.

Adjusting these did not raise the speed of the connection.

I am gonna go on guess work here but it appears simply that this router cannot handle a 20mb connection.

If anyone can offer advice I'd would really appreciate it.

edgepcs
06-23-2009, 12:55 PM
Try putting the firewall on the PC and then see how well it runs putting it in the routers DMZ. Then you can at least tell if it is a router setting problem.

MM PC Solutions
06-23-2009, 04:17 PM
Put PC's in DMZ with firewalls on & still poor.

Connected PC's direct to modem with with firewall on, both worked very well.

I took a Belkin round, installed that & all worked as it should do.

The netgear is getting returned.

anonymous Mac Tech
06-23-2009, 04:37 PM
Sometimes a hard reset will do wonders. Especially for Netgear boxes as I've personally encountered. Just backup the settings and it should only take 2 minutes. Just check netgears knowledge base for the proper procedure. If I remember correctly for the WPN824v2 it was plug in the power while holding in the reset button for at least 30 seconds.

Jory
06-23-2009, 11:23 PM
Does one of the PC's only have a 10Base-T network card? It shouldn't matter on a router, but you never know. It probably wouldn't hurt to swap cables either.

Try unplugging all computers and then check only one at a time and see if they're all getting the same speed when only one is hooked up. If none of that works try doing some google searches and see if anyone else is having the same problem.

edgepcs
06-24-2009, 07:43 AM
Does one of the PC's only have a 10Base-T network card?

Also check the driver settings even if the card is of higher speed. I have seen it before where some how the driver settings were set to 10base-t on a higher speed card and that caused all sorts of hell as it was used to run a large format printer.

MM PC Solutions
06-24-2009, 07:48 AM
Thanks for all the suggestions but my sister has convinced herself that she is returning the netgear & sticking with the belkin I installed.

edgepcs
06-24-2009, 09:59 AM
TBH that is generally the best thing to do if it is a brand new router and you can't get it working after an hour.
I have worked on routers for more in the past (not recently though) because I hate feeling like it has defeated me :mad:

MM PC Solutions
06-24-2009, 07:21 PM
If I was allowed, I would tinker with it until I figured it out (that's why we do what we do).

TazUk
06-24-2009, 08:46 PM
Maybe the Netgear only had a 10mbit WAN port :confused:

TazUk
06-24-2009, 09:41 PM
To answer my own question, the WGR614 v7 does have a 10/100 WAN port so it may be negotiating the speed incorrectly.