PDA

View Full Version : Wireless Networks and business clients


kc0eks
02-10-2009, 04:30 PM
Hello,

I have a few business clients that use wifi on their laptops. It seems like some of these laptops have constant issues with dropping the connection. And then they just randomly connect to whatever network is near. This causes their drive mappings and other software to fail.

The network is on a channel no others use. It is using WPA encryption.

Any solutions others use? Reconnecting is easy, for me, but the less tech savy have problems getting it to the right network.

Flyingbull
02-10-2009, 05:03 PM
It depends on a number of factors, if you are using windows to manage the connection, then you need go into the properties of the wireless connection, then into advanced. There you uncheck the box that says Automatically connect to non-preferred networks. For any other software that might be managing the connection, you need to discover the equlivalant settings. Remove any networks that are already there that you don't want on the list, and that should solve that problem of multiple networks.

kc0eks
02-10-2009, 05:12 PM
I forget you cant read my mind...hah.

It is windows XP on all the laptops. SP2 I believe.

I had this happening on another laptop and just got sick of it and replaced the wireless card, which seems to have fixed the problem.

I am just wondering if their are any standard tricks anyone uses to make windows wireless a little easier on the end user.

As for the tip you gave, I swear I have repeatedly disabled the auto connect to non prefered...it either ignored me or comes back.

Regardless I just want to make it as easy as possible for the end user to connect to a certain wireless network.

Thanks!

TimeCode
02-10-2009, 05:16 PM
There you uncheck the box that says Automatically connect to non-preferred networks.

That's what I was going to say.

As for the tip you gave, I swear I have repeatedly disabled the auto connect to non preferred...it either ignored me or comes back.

That, at least to me, signals that there are more serious issues involved. I'd check out registry settings but I have Windows 7 on my laptop.

Flyingbull
02-10-2009, 05:22 PM
As for the tip you gave, I swear I have repeatedly disabled the auto connect to non prefered...it either ignored me or comes back.

I ran into this before, when my Toshibia would do that, it was because the software that they provided to work with the built in wireless would keep pinging the network and doing an autodiscovery. How I finally got it under control (because I preferred usiing Windows to manage it - I'm sure if I wasn't cranky with it, I could have just updated it to stop doing the auto discovery), I had to look at the start up options in the registry and take out the software start up. Once I did that, no more problems.

gadz00ks1
02-10-2009, 07:02 PM
I had something similar happen to me and I had to update the wireless drivers on the NICs.

seedubya
02-10-2009, 07:06 PM
Normally I uninstall any card specific connection manager and just run with WZC, this (and tweaking whatever firewall they use) has solved 99% of my wireless problems.

kc0eks
02-10-2009, 08:07 PM
Thanks for all the help everyone. This is my first tech question here (longtime blog reader though) and the quick response and ideas was perfect.

TimeCode
02-10-2009, 11:22 PM
kc0eks, I'm glad you got your answer. Everyone here is friendly and willing to help others.

Normally I uninstall any card specific connection manager and just run with WZC

Ditto. I never even though about that because it is almost automatic for me.

Y.F.N.C.G.
02-11-2009, 04:07 AM
Are these their laptops from work or their personal laptops? If they are laptops from work, they may be under some kind of active directory group policy that reverts the wireless settings back (re-check's that "automatically connect" box) when they connect to their corporate network during the day. The setting would then be retained when they are at home.