PDA

View Full Version : Printer Sharing Issues


MSgherzi
02-07-2009, 06:06 AM
I decided today to use one of my old Desktop's that I don't use anymore for a file and printer server. I enabled it and all drivers are installed. The computer that the printer is connected to via USB is XP and my laptop that I'm trying to access it with is Vista.

I actually have these two computers bridged via Ethernet because the XP machine doesn't have wireless and my USB adapter doesn't support WPA2, so I connected it to my laptop with a really long Ethernet and I have the connections bridged.

I added the local port \\USER7\PIXMA as directed. Now, when I try to print on my laptop it simply sends it and nothing happens. As a matter of fact, the physical printer never even receives the document. I can't find the IP address of the printer, either. I tried opening up some ports for my Vista laptop on my Linksys WRT54G, no luck. I also have a VPN called iPhantom, but I don't think that's the issue, in my opinion.

I enabled NetBIOS over TCP/IP on my Vista machine, and the XP machine has the port for the printer set on USB. I tried spooling it with the \\USER7\PIXMA port and USB, no luck.

Again, all drivers are installed on both computers and when connected via USB, both computers print fine. On my Vista laptop it says that the printer is offline while the XP machine says it's online, obviously. Also, when I try to add a new printer and I search on the network, it comes up with nothing. And I cannot even try to re-add the local printer port for the network path because it tells me "Access is denied." As of now, the port is still added from earlier, though. I can ping USER7 but not USER7\PIXMA or \\USER7\PIXMA. My assumption is that it isn't really connected to the network properly.

The printer is a Canon PIXMA ip1500

Any suggestions?

Thanks in advance,
Matthew

MSgherzi
02-07-2009, 06:31 AM
Okay, never mind. Murphy's law seems to hit me whenever I post these threads. I fixed the problem already.

I simply added a new printer a changed the name. On the Vista laptop I added it in a different way.