PDA

View Full Version : Exchange 2007 and no-ip help


itech88
07-01-2012, 04:31 AM
I am wanting to switch my email from my hosting provider to my own server. I would still like to host the website with my hosting provider(hostgator) but move mail to my server. I have a dynamic ip and my isp is not blocking port 25. I have a no-ip plus account also. The server that this will be set up on is Server 2008r2 and has Exchange 2007 on it. I am needing some help with mx records, dns, config of Exchange to start sending and receiving mail, i have an untangle box setup and have forwarded port 25 to my soon to be mail server. This is my first time dabbling with exchange so if someone has some good documentation or tips for me that would be great.

Thanks

OfficeTechs
07-01-2012, 08:14 AM
get a static ip for starters.

Parkwaytech
07-01-2012, 05:18 PM
Definitely get a static IP. Also, why Exchange 2007? You should be using Exchange 2010. And, if you haven't installed Exchange before I recommend trying this with a test domain first. Don't risk your own email until you know what you are doing.

cooltech
07-01-2012, 05:33 PM
i think that is what no-ip does. Since this sound like a house ip.
Have you thought about Zimbra open source? http://www.zimbra.com/products/zimbra-open-source.html http://www.zimbra.com/downloads/os-downloads.html

This might be an easier way. And you can always virtualize this, it if want too.

techmaverick85
07-03-2012, 10:33 AM
As you're just dabbling, a dynamic IP is OK...I would recommend using a smarthost though for outbound email (Hub Transport > Send Connectors> Modify the * connector, and specify 'route mail through these smarthosts' - or something along those lines) as sending from a dynamic IP will mean some email won't get delievered.

setup a cname for 'mail.yourdomain.com' point it at your no-ip record

set up an mx record with a priority of whatever (lowest number) and point it at mail.yourdomain.com

Your firewall config seems to be OK.

Also, make sure you specify your domain name in accepted domains within exchange too. That should be about it!

itech88
07-04-2012, 04:28 AM
Thanks, for the replies so far. I went ahead and ended up uninstalling Exchange 2007 and installed Exchange 2010. I am currently running into some problems though. Before i was able to successfully send email out. Now after upgrading to 2010 I am able to send mail out but am not able to receive. I am stumped now, i have made sure all my accepted domains are set, set up a Test received connector, set up send connectors(this most be properly configured if i am able to send messages out now. Any suggestions to why i can't receive messages now.

Thanks

itech88
07-04-2012, 04:34 AM
Thanks, I have set up a smarthost for the outbound mail. And everything is configured for mx records pointing to my exchange server. I have setup several different authoritative domains in accepted domains. Any ideas why i am not able to receive mail, but i can send mail out?

Thanks

As you're just dabbling, a dynamic IP is OK...I would recommend using a smarthost though for outbound email (Hub Transport > Send Connectors> Modify the * connector, and specify 'route mail through these smarthosts' - or something along those lines) as sending from a dynamic IP will mean some email won't get delievered.

setup a cname for 'mail.yourdomain.com' point it at your no-ip record

set up an mx record with a priority of whatever (lowest number) and point it at mail.yourdomain.com

Your firewall config seems to be OK.

Also, make sure you specify your domain name in accepted domains within exchange too. That should be about it!

techmaverick85
07-04-2012, 07:27 AM
Without looking at your exchange server, you need to allow anonymous users on your receive connector under 'Permission Groups'.

This assumes the rest of the receive connector has been set up correctly. They are correct when you first install Exchange, apart from the anonymous users group as per above.

See how you get on with that, and then post back.

PS, seeing as you've reinstalled exchange
Double check your firewall is letting port 25 thru, and NAT is pointing it to to your Exchange Server (if the internal IP has changed)

itech88
07-04-2012, 03:23 PM
Thanks for the help, after several hours of testing different things out, checking the Exchange Remote connectivity analyzer and the tips that i got i was able to finally get this working! It was a combination of several things that, after i had setup port 3325 to forward to port 25 i was able to receive mail, but then i also had to just forward port 25 as well. Then as far as receiving goes, i had to allow anonymous users as you suggested, and open port 443. Well after several hours of messing with this, i think i might have a grasp on this now. Just in time before i have to go deploy Exchange 2010 at a client later this week.

Thanks Again

Without looking at your exchange server, you need to allow anonymous users on your receive connector under 'Permission Groups'.

This assumes the rest of the receive connector has been set up correctly. They are correct when you first install Exchange, apart from the anonymous users group as per above.

See how you get on with that, and then post back.

PS, seeing as you've reinstalled exchange
Double check your firewall is letting port 25 thru, and NAT is pointing it to to your Exchange Server (if the internal IP has changed)

techmaverick85
07-04-2012, 04:02 PM
I don't quite understand what you mean by forwarding port 3325 to port 25? Never heard of that before... Unless it's some strange outbound email configuration?

You should only really have 25 and 443 open inbound. 25 for inbound mail, and 443 for OWA, Outlook Anywhere, ActiveSync etc.

I didn't realise you were setting it up in a production environment soon. it sounds like you're quite new to it (no offence :) ) so perhaps use the following link to build your solution

http://technet.microsoft.com/en-us/exdeploy2010/default.aspx#Index

I'm an Exchange consultant, so can give you some best endeavours advice while you're on site if I'm about.

itech88
07-04-2012, 04:39 PM
Hmm, well with having it setup through no-ip, my isp is blocking outbound port 25, so i had to set the the send connector ( Set-SendConnector -Identity " "-port 3325) this way i can send mail out. Does this make sense?
And yes I am quite new to Exchange, but better testing and learning before getting on-site. Thanks for that link to I am checking that out now.
Could i get your email if i run into any issues while setting this up?

Thanks

I don't quite understand what you mean by forwarding port 3325 to port 25? Never heard of that before... Unless it's some strange outbound email configuration?

You should only really have 25 and 443 open inbound. 25 for inbound mail, and 443 for OWA, Outlook Anywhere, ActiveSync etc.

I didn't realise you were setting it up in a production environment soon. it sounds like you're quite new to it (no offence :) ) so perhaps use the following link to build your solution

http://technet.microsoft.com/en-us/exdeploy2010/default.aspx#Index

I'm an Exchange consultant, so can give you some best endeavours advice while you're on site if I'm about.

techmaverick85
07-04-2012, 06:20 PM
Sure.

If you PM me with your details, and I will reply, so you've got mine.