PDA

View Full Version : M5030 Powers From Battery, No Charge - DC Jack Replaced


Adept PC Repair
05-05-2012, 06:13 PM
Hi,

I have a Dell Inspiron M5030 here which does not charge, the laptop is in full working order apart from that.

I have replaced the DC jack to no avail, I am pretty much at a loss as to where the fault could lie, there are no obvious damaged components on the board.

Any help would be appreciated.

Thanks,
Ian

732914TECH
05-05-2012, 07:36 PM
does it say plugged in not charging in windows? if so its probably a bad ac adapter. the center pin is not working correctly and allowing the laptop to charge the battery

Adept PC Repair
05-05-2012, 08:45 PM
I've tried my universal adapter and its the same. No, it doesnt say plugged in, its as though there is no charger connected at all.

732914TECH
05-05-2012, 09:56 PM
ah ok id say theres a blown fuse somewhere near the dc jack then. is the dc jack on a seperate PCB ?

Adept PC Repair
05-05-2012, 10:12 PM
Unfortunately not on this pcb. I would have just bought the daughterboard to save hassle otherwise.

I'd rather go the smd replacement route than replace the board, i've already placed a blob of solder over what looks like the fuse to no avail, the laptop still powers via battery.

SprinterTech-WI
05-05-2012, 10:39 PM
I have the same problem on a 6040 PP20L - it's a bad Ram controller, and only option is a mobo replacement unfortunately...... at least for me I could get the charging lights to work if I had both Ram sticks out, it would work great (well except it wouldn't boot with no ram) but as soon as any ram was installed, BAM doa!

phaZed
05-05-2012, 11:02 PM
I'd rather go the smd replacement route than replace the board, i've already placed a blob of solder over what looks like the fuse to no avail, the laptop still powers via battery.

Placing a blob of solder on a component in which you "think" is the fuse is usually not a good idea. You should be using a multimeter to test. Is the DC jack getting power.. is the board getting power, etc.

Jumping components at-will usually has ill consequences.

Adept PC Repair
05-06-2012, 12:27 AM
I do have a multimeter but find it a load of tosh tbh, I have found an apparant faulty mosfet in the past, replaced it only to find it not to fix the problem.

The fuse i jumped is definitely a fuse due to the label on the board, its just whether it is a fuse for the dc jack, though it must be, thinking about it.

My multimeter shows 19v from my universal charger going through the board, which confuses me. How can a ram controller cause a motherboard not to charge? I didn't even think they were linked?

AlaDes
05-06-2012, 12:55 AM
Are you sure you got all the pins soldered in good? Just remember, a motherboard has several layers in which the pins may have to make contact, so simply checking the voltage on the soldered side may not always yield accurate results, especially if the solder hasn't flowed completely through.

Adept PC Repair
05-06-2012, 02:56 AM
I am sure it is all soldered well. The original jack looked undamaged, only replaced it out of routine.

Adept PC Repair
05-07-2012, 03:03 PM
Only thing I may be missing here is the fact that he didn't supply me with a charger, i'm using my universal charger which has always worked on dells no problem, apart from it may not charge the battery, but it does power them.

I tried with ram removed and it's the same, not a faulty ram controller. I'm going to take a multimeter to it tomorrow when i'm back in the office to double check where voltage stops, if at all.

732914TECH
05-07-2012, 03:59 PM
try to get your hands on a real dell charger for it. dells can be very picky

Adept PC Repair
05-08-2012, 05:31 PM
Tested today with multimeter.

19.5v going through the jack and half of the board, the other half of the board has 9v going through it.

New board, not wasting my time with it, it's incredibly hard to pin point.