PDA

View Full Version : White screen, intermittent with vertical lines then constant white screen


mriv1
08-03-2011, 02:40 AM
I have a Dell 1555 laptop that had intermittent vertical lines and sometimes a white then black screen depending on how I moved the display (hinge defects on these things are TERRIBLE btw). Then, I saw what looked like smoke at one point, but now I think it may have only been dust? Was really confused at that point. I shut the thing down and restarted it and there was no more of that.
The same thing occurred as above, with the intermittent problems, until the screen went black only first, then white only. The OS was booting at times, with the windows startup/login sound, but no longer does that, although sometimes it does boot, other times it doesn't. There are no beeps either.


This is confusing, I haven't done anything with it yet though, just kindof fiddled with it for a few in the early evening, I'm gonna look at it tomorrow, just wondering what you guys think it could possibly be.

I have my own ideas..

Knightsman
08-03-2011, 03:44 AM
well, if your having issues with it sometimes working, sometimes not. that could be bad hardware.

If your having issues with video while and ONLY when you are moving the screen then I would say a bad video cable to the LCD.

If your having these issues without moving the screen, and the screen never fixes itself no matter what position your in, it could be a bad mobo or cable.

Try a secondary monitor and see how it does.

gazza
08-03-2011, 03:45 AM
Your lcd screen needs replacing.

Knightsman
08-03-2011, 05:41 AM
Maybe im confused, do you only get the white or black screen with lines? Or do you also get a normal picture?

Sent from my DROID2 using Tapatalk

mriv1
08-03-2011, 05:43 AM
I'm pretty sure that the uh, white smoke that I saw, was the lcd cable, the.. damn i feel so stupid right now I can't word anything right, the insulation to the cable is stripped and the wires don' look horrible but they're exposed and so I think that it might be worth replacing the ribbon cable first, before getting the whole screen fixed. I tried to get to BIOS but F2 just beeped.


I'm learning more everyday, at least.

mriv1
08-03-2011, 05:45 AM
Now its only a full white screen, I tried using the VGA to an external monitor and i didn't get any signal..


I really do feel as if its the cable though.

gazza
08-03-2011, 06:01 AM
In my experience ribbon cables for LCD monitors rarely fail, I have seen these symptoms before in a laptop that is booting correctly and they have always needed a new screen.

I read your post again, Did you say you saw smoke? Is there any burning smell coming from the laptop?

mriv1
08-03-2011, 03:11 PM
No burning smell, from what i can remember. Smoke was white, like the color of the insulation around the wiring. The hinges and bezel are all wacked, and I think that it chewed at the wiring over time. the wires themselves look fine, but in my experience when the insulation/cover whatever you wanto call it around them has frayed it causes a problem.

Do you think that i should just get a new screen for the thing then?


I know this is going to sound really pathetic, but can you help me with backing up this machine if I can't get a second monitor to work on it??

Honeymonster
08-03-2011, 11:50 PM
Now its only a full white screen, I tried using the VGA to an external monitor and i didn't get any signal..


I really do feel as if its the cable though.

Did you try hitting the function key and F8 when you had it hooked up to an external monitor? That toggles the display setting from the LCD to the external screen. If you just hooked it up and didn't do that you wont get a signal to the external screen.

mriv1
08-04-2011, 01:02 AM
Did you try hitting the function key and F8 when you had it hooked up to an external monitor? That toggles the display setting from the LCD to the external screen. If you just hooked it up and didn't do that you wont get a signal to the external screen.


I did, I actually had to unhook the monitor from the laptop, THEN it worked. i posted another thread on this whole thing. Since I'm looking to start a business in the future, I'm really trying to get a leg up on every single thing that I can encounter when I do go into this in the next couple of years, when I'm finished with school and all. I managed to get the screen up ONLY in safe mode, and I'm getting 8 beeps..

phaZed
08-09-2011, 08:53 PM
I would start with the LCD cable. It obviously needs replacing and is cheaper to start with than an LCD. One thing is for sure.. if the LCD cable is grounding to the hinge/frame then you are sure to have all sorts of LCD problems.. if not now then shortly. The smoke you saw was probably from the LCD cable shorting out on the hinge (12v supply). I see worn LCD cables all the time.