PDA

View Full Version : Windows Explorer Crashing


Goob
07-13-2006, 11:36 PM
Hey all, am having a big problem with my windows explorer. It crashes when ever I try and view one of my HDD's. I've read up on the error and have got no help from what I've read.
Details:
HDD is a drive connected to my IDE raid card, its a 200gb and its not even a year old. Drive worked perfect on windows vista and windows xp before i installed vista, but now that I'm back to xp its had problems. This is just a drive I store TV shows etc on.
I did manage to read a lil of one of the errors, it had something to do with appcompat, or something file.

Any help would be greatly appreciated

Bryce W
07-14-2006, 05:52 AM
You've mentioned its on a IDE/Raid combo card, but I am assuming that the harddrive is IDE and not setup as raid.

What is the exact error message?

Is it only when you view that drive though explorer? will it happen if you try to save a txt file from within notepad into the root directory of that drive? (in List view mode)

Are there movie files in the root directory you are trying to list?

If the error was with appcompat.txt, then that is just Windows error reporting and not the actual issue itself. It sounds like you might have a corrupted video file in the root of that drive and your Explorer is in thumbnail view. When you open that harddrive it tries to make a thumbnail of a corrupted video file and crashes.

Let me know the answers to the above questions and I can give a better answer of what it is.

Goob
07-14-2006, 01:57 PM
The exact error message doesnt really say much except for its an unknown error. The files im trying to view are in a folder within the root directory. I've turned off thumnail view to see if that helps, and so far so good. Will keep you posted

Goob
07-14-2006, 09:42 PM
Update:
Windows explorer crashes when ever I browse a folder containing a few video files and it happens on any of my 3 HDD's. Now its not even giving me an error message, it just restarts explorer.

Can anyone help me as this is ******** me to tears

Bryce W
07-15-2006, 01:27 AM
Ok, there is a short way and a long way to do this, we'll try the short way first:

Click the Start button, click Run on the Start Menu, type in REGEDIT. Navigate on the left pane of the Regedit window to the following key:

HKEY_CLASSES_ROOT\SystemFileAssociations\.avi\shel lex\PropertyHandler

Then, in the right pane, after clicking on the PropertyHandler key in the left pane, you will see the Default value which should be

{87D62D94-71B3-4b9a-9489-5FE6850DC73E}

Highlight the value, goto File > Export and place it in a safe place, this will make a backup.

After that Right click on the value and select Delete from the Context Menu. Then close Regedit.
Restart your computer and give that a shot. If it doesnt work, click on that registry key you just exported and it will return it back to normal.

Arden
07-15-2006, 02:34 AM
I would also like to ask you to check your proccesses running for avp.exe

edit: Ey Knuckles, I tried finding it.. but I don't even have the SystemFileAssociations map XD

Goob
07-15-2006, 02:40 AM
I tried something else first, i read up on the codecs and problems people have had with corrupt codecs causing this problem. So I uninstalled all codecs and so far so good. VLC doesnt need codecs as it has most in it. So all good so far, will keep you updated