PDA

View Full Version : MS Access Issue driving me NUTS!!!


crabig
06-22-2011, 06:27 PM
Here's the setup:

3 machines on a small network. 2 running Windows 7 64, one running Vista 32. All three machines are using MS Office 2010.

Machine 1 - Windows 7, hosts the database in a shared folder.

Machine 2 - Windows 7. See the database file, but it is showing as a zero file size. A different database in the same shared folder is seen normally, and opens with no problems.

Machine 3 - Vista 32. The database file works perfectly.

My conundrum:


If the database was bad/corrupt, it wouldn't open on any of the machines


If MS Access on Machine 2 were bad/corrupt, it wouldn't open other databases in the same shared folder.


If it were a sharing issue, it wouldn't affect the Vista computer


I've been fighting this part-time for about 2 weeks, now. I can't come up with anything else. I'm open to suggestions.

Thanks in Advance

JustMe
06-22-2011, 06:44 PM
We'll start here...

Does Machine 1 have Access 2010 installed? If so, does the database open on it as well?

Does Machine 2 have the x32bit or x64bit version of Access 2010 installed?

Does that different database open correctly as well in Machine 3?

Did the file ever work in this setup? If so until when?

Is the database running concurrently on both Machines 2 & 3?

crabig
06-22-2011, 07:06 PM
Machine 1 has the full Office 2010 Suite installed, including Access. It is 64 bit. This is where all the database changes take place. The users on Machine 2 & 3 only read the database, although they are capable of changing it (in theory).

Machine 2 has 64 bit Office 2010 w/Access

Machine 3 is running 32 bit. It can open the other database.

It has never worked correctly in this setup. It worked when Machine 2 was running Windows XP.

The big puzzle for me is why this is showing as a zero byte file.

JustMe
06-22-2011, 07:54 PM
You probably tried this already but...

Can you make a new shared folder and copy the database file into it to see if it opens on Machine 2? This way you can verify permissions...

crabig
06-22-2011, 08:02 PM
Before I worry about getting it opened, I need to figure out why it's showing a zero file size. Even if permissions were not set, it should show the correct file size in the Explorer listing.

I have a feeling that once I get that fixed, the other issue will correct as well.

mm201
06-22-2011, 09:06 PM
I've had pretty good luck with Access problems over at the Utter Access forum. There's a bunch of Access gurus who are pretty quick to give a response.

http://www.utteraccess.com/

crabig
06-26-2011, 05:46 AM
Thanks for all those who chipped in advice... the problem apparently was in the share process.

I moved all the database files into a new folder, rebuilt the share to the new folder, and it worked great!!

Still can't figure out why it came up showing the zero size file, but the client is happy that all is working.