PDA

View Full Version : Packard Bell Odd Colour Output (Attached Video)


Simmy
06-25-2008, 10:41 AM
I've got a Packard Bell R1000 in parts at the minute and I'm trying to determine what the problem is. As soon as I press down on any part of the chassis, the colour on the display becomes faded as shown in the video.

Video (4.5Mb) (http://www.smg-computers.com/hosted/25062008001.mp4)

I've never seen this before, but I'm guessing the graphics chip is knackered and would mean replacing the whole motherboard. It doesn't appear to be anything to do with the ribbon cable or LCD. I've tried hooking it up to an external monitor to see if it shows the same thing, but I can't get it working for some reason. When I press the external monitor function key, the laptop LCD goes black but nothing is displayed on the external LCD.

I've tried reseating the CPU and some new RAM. Most of the other components have been removed to make it easier. Any suggestions appreciated.

thecoldone06
06-25-2008, 10:47 AM
Is it when you press anywhere on the chassis or only on the part that you were pressing on in the video?

Simmy
06-25-2008, 12:25 PM
It's slightly intermittent if you press/move other parts of the chassis. But it's guaranteed to do it if I press the spot as shown in the video. The graphics chipset is directly below that point too which is why I think that's the problem.

thecoldone06
06-25-2008, 12:37 PM
Yeah I'd say thats your problem to. My vote is also a MOBO replacement. Probably not the suggestion you wanted to hear but sounds like thats going to be the solution.

generalj
06-26-2008, 12:48 AM
I wonder if its a short somewhere. try to ground the part you are touching to something other then the computer itself and touch it.

Simmy
06-26-2008, 10:15 AM
Well, I managed to get the external monitor working (turns out it didn't like running through my KVM switch). The picture on the external monitor is perfect :confused: So it could be the LCD or the chipset. Wiggling the ribbon cable doesn't alter the picture so I don't think that's the problem.

I tried your suggestion generalj, but it doesn't seem to make a difference. Simply applying pressure over the chipset fixes it, even if I apply pressure to the plastic chassis. You're right though, it could be grounding something inside when pressure is applied.