PDA

View Full Version : Services.exe - Unable to locate component


Compbck
09-02-2010, 02:09 PM
I have been working on a Windows XP Pro computer displaying the following message:

Services.exe - Unable to locate component (This application has failed to start because umpnpmgr.dll was not found. Reinstalling the abpplication may fix this problem).

I have tried just about every suggestion on the Internet - Have replaced the umpnpmgr.dll file from the existing i386 folder of the Acer PC, used Recovery Console to copy across the same file, tried system restore etc, but the PC still boots with the same message.

I am trying desperately not to resort to reinstalling Windows because there is an online finance package installed, which will cause problems for the user if deleted during a reinstall process.

Has anyone met this particular problem before and resolved it satisfactorily without resorting to reinstalling Windows.

Regards to all.

computerdoc
09-02-2010, 02:13 PM
I assume that you registered the dll when you replaced it.

A repair install shouldn't damage your existing configuration.

Reimage is also a possibility.

iisjman07
09-02-2010, 02:59 PM
Check the 'UPnP Device Host' service is set to Manual, and also make sure the 'SSDPSRV' service is set to manual as well. I extracted the registry information relating to these services on my vista machine; try adding it (after backing up the current registry of course):

If that doesn't work then extract the registry info from an XP machine (sorry I don't have access to one at this second). If that still doesn't work then try disabling the UPnP Device Host service and see if the issue still occurs
Reg.zip