PDA

View Full Version : Interesting Filesystem Problem with Norton Security


drewster
07-08-2010, 05:38 AM
Had a headscratcher today, maybe this will help someone else in the future.

Customer was complaining that his computer was wanting to run chkdsk on almost every boot. Also, his Norton Security Suite program was not working.

Ran through the typical things; the hard drive passed diagnostic tests, RAM passed tests, and ran several thorough chkdsk scans on drive.

Ran several thorough virus scans. Ran full Norton Removal Utility.

Cloned drive to new hard drive. Tried different cables. Even tried a new motherboard to rule out a flaky hard disk controller.

What finally gave me a clue was running a "dir /s" from the root directory of drive, the program eventually errored out trying to read from the "C:\Documents and Settings\All Users\Symantec folder. There was a subdirectory that the system could not read from. I tried manually deleting the files and it would not delete.

I ended up booting to a live Ubuntu disc and then was able to delete the folder. Once that done, file-system problems cleared up and was able to successfully install Norton and not get the file-system errors.

Found this article that probably is related, but of course customer did not want to format:

http://support.microsoft.com/kb/246026

bensthelens
07-08-2010, 08:26 PM
Hey,

I had that exact problem before..except I resolved it differently..

I cancelled the scheduled disc checks with "chkntfs n /x" with n being the drive letter.

I then used unlocker to delete the file.

Ben