PDA

View Full Version : Windows Installer Service could not be accessed


Omegaspectral
06-28-2010, 10:36 PM
Hi I am new to this form and I am looking for some help.

I have a clients computer who was having a problem with his start bar and just about everything else disappearing. Anyways after an intense virus removal we decided to do a repair install. This fixed the start bar issue and we thought we were done. On almost all computers we try to install Windows Defender for customers to have some type of protection. This is where the problem came in. I am getting "Windows installer service could not be accessed" So the first thing I try is starting the service. tried to install again, still no luck. The service "seems" to be starting fine but anytime I try to run anything that depends on the windows installer I get the same error. I have tried many things with still no luck. So I open up event Viewer and see this:

The description for Event ID ( 1015 ) in Source ( MsiInstaller ) cannot be found. The local computer may not have the necessary registry information or message DLL files to display messages from a remote computer. You may be able to use the /AUXSOURCE= flag to retrieve this description; see Help and Support for details. The following information is part of the event: 0x80070005, (NULL), (NULL), (NULL), (NULL), , .

I have tried this:
http://support.microsoft.com/kb/315353

and this:
http://support.microsoft.com/kb/324516

Also I have tried re-installing Windows Installer. With no luck. Tried Dial-a-fix..no luck. So I am desperately running out of ideas.
Anyone seen this before?

stevenamills
06-28-2010, 10:55 PM
Have you tries resetting permissions back to default? Can't hurt.

trapped
06-28-2010, 11:05 PM
Why would you use Windows Defender? There are plenty of free antivirus products out there including Microsoft's Security Essentials.

I had a situation where the computer thought it was in safe mode even though it was booted normally. Check out this thread, http://superuser.com/questions/42869/print-spooler-thinks-regular-mode-is-safe-mode.. There are a number of services that are not available in safe mode including the installer service.

Omegaspectral
06-28-2010, 11:19 PM
We have tried Subinacl If that is what you are talking about. That failed because It uses Windows Installer as well.

Anyways Im not here to go into politics of who should use what program. Im just here to get help to a problem that I am facing.

Omegaspectral
06-29-2010, 08:33 PM
Fixed It!!!!!!!!!
The RPC service was not set to Local System Account. Everything is back to normal and Windows Defender is running along side Windows Updates