PDA

View Full Version : Help running old DOS program over network


JRDtechnet
01-23-2008, 05:35 AM
This going to be long but please bear with me.

There are 2 computers running windows 98 using an old DOS program called Fingertips(like an invoicing program for mechanics I think). According to them they used to be able to access the program over the network (just a hub).

On the computer the program is installed on I'll call it the 'server'
and on the computer that doesn't have the program I'll call the client.

Now the way the program lauches is very strange but heres what I got.
the MSDOS shortcut is linked to a batch file and the batch file is launches the actual program.com. Now the batch file passes along the username and location of the work files to the program. However just clicking on the batch file gives an incorrect password error. Finally examining the shortcut it goes something like this 'c:\fingertips\batch.bat ym' the YM seems to be the password since editing that out of the shortcut makes the same missing password error.

Now that I've established that, lets move on to the client computer.
On the client computer the customer shows me that she used to launch the program with a shortcut.

I click on it DOS windows pops up 'file not found/missing'. Examing the shortcut shows 'c:\fingertips\batch.bat ym' so the shortcut is pointing to the local drive not across the network...I ask again if she was sure she used to run the fingertips program by clicking that shortcut...she insisted yes, just last week. (I kinda doubt that now, it would of been impossible with that shortcut at least)

Alright so I change the shortcut to unc paths, still get missing file error...because the batch file also had local paths...even though the batch file was on the server it still said c:\ which made the client computer look on its own drive. So I copied and renamed the batch file on the server pc and changed the paths to unc paths. Now clicking the program on the shortcut on the clients computer launches the program....alas I get a missing password error. Even though I have the 'YM' at the end of the shortcut unc path.

So how do I get the YM across the network?? thanks for your help.

Holzster
01-26-2008, 02:52 AM
Guessing here - can it not handle TCP-IP - was NetBUI on the machine before?

Is it going through a router now? NETBUI can not go over a router just hubs - If I am remembering right

Holzster