PDA

View Full Version : System Tray Won't Respond


ninjaman001
11-27-2007, 05:36 PM
I ran into a strange ish yesterday. A pc that will boot, but I can't get anything in the system tray or on the lower toolbar to respond. Desktop icons will work fine, but "start", quick launch toolbar, systray icons; none of these will respond.
I've booted it into safe mode, ran hijackthis, spybot, adaware, avg spyware, stinger, trojan hunter, almost everything I have, I've thrown at it. I've uninstalled a lot of things that were questionable, but frankly I'm stumped. Anybody seen anything like this? Any help or a kind word of prayer will be much appreciated. ;)

JohnR
11-27-2007, 07:03 PM
Thought #1: Remove your desktop background picture.

No, seriously. There's an old trick involving taking a screenshot of the desktop, setting the screenshot as the background picture, and then hiding some or all of the icons or toolbars. It drives people NUTS.

So get rid of the background picture. If your "start bar" disappears along with the rest of the image, you've got a prankster. Run your mouse around the edge of the screen until the real start bar (probably on the right-hand side) pops itself out.

Thought #2: Open the task manager. Kill explorer.exe.

If it doesn't restart itself, manually start it from the "new task" button in the task manager.

Is it working now? If so, it's something about how Windows starts the task. Not sure how to fix that, without a reinstall.
Is it still broken? Then explorer.exe is broken. Not sure how to fix that, without a reinstall.

But I think you might be reinstalling Windows.

(Also: It may seem that my default solution to EVERYTHING is "bare metal recovery". This is because my default solution to everything is bare metal recovery, or, at least, to everything software-related. It fixes your target problem AND all the other lurking problems, at the same time, and it's often faster than spending hours troubleshooting why it is that Windows isn't working quite right. But, again, I don't work with home users, almost ever.)

gunslinger
11-27-2007, 07:25 PM
Restarting explorer.exe should work it has for me in the past. If that fails you could try to " repair windows" with the install disk.


"(Also: It may seem that my default solution to EVERYTHING is "bare metal recovery". This is because my default solution to everything is bare metal recovery, or, at least, to everything software-related. It fixes your target problem AND all the other lurking problems, at the same time, and it's often faster than spending hours troubleshooting why it is that Windows isn't working quite right. But, again, I don't work with home users, almost ever.)"

You are right JohnR, I like the way you think.

JohnR
11-27-2007, 07:29 PM
Additional thought: Do the keyboard shortcuts cause a response? CTRL-ESC to open the Start Menu, or just the Windows Key tapped once. Can you return to desktop with Windows-D or lock the machine with Windows-L?

If those are working, explorer.exe is working. It's certainly very odd that it's not clickable, but still. Odd.

Bryce W
11-28-2007, 04:01 AM
Goto MSConfig and disable all startup applications. There could be an application that causes it to hang when it starts at boot-time.

Also look at the system services. I have seen similar when a Service was hanging at boot time. Look at the state of the services and look for one that is stuck on "Starting..". Try disabling it and see if this fixes it.

ninjaman001
11-28-2007, 12:33 PM
Thanks Guys,

I killed explorer and then restarted it through task mgr. That brought the responsiveness back, but I still can't determine what's causing this. It's time for the "R & R"; repair and/or re-install. ;)

gunslinger
11-28-2007, 12:51 PM
Yup, when all else fails, nuke it. Its quick painless and works almost 100% of the time.

Bryce W
11-29-2007, 04:01 AM
Before you nuke it, try this:

1. Disable "Automatically search for network folders and printers"
- Go to Control Panel and run Folder Options. Click the View tab and uncheck "Automatically search for network folders and printers"


2. Delete any unused network Printers.
- Go to Control Panel and run Printers and Faxes. Delete any unused network Printers by using your mouse to right click and select Delete.
3. Delete automatically found network shared folders.
- Go to My Network Places and delete the found shared folders.
4. Delete mapped drives.
- Go to My Computer and delete any mapped drives.
5. Hide icons for networked UPnP devices.
- Go to My Network Places and on the left pane, click "HIDE icons for network UPnP devices". If it says "SHOW icons for networked UPnP devices", then it's currently hidden. You can skip this suggested step.


6. Disable "Background Intelligent Transfer Service".
- Go to Start -> Run and type msconfig. Click on Services tab and uncheck Background Intelligent Transfer Service to disable it.
7. Disable "SSDP Discovery Service".
- Go to Start -> Run and type msconfig. Click on Services tab and uncheck Background Intelligent Transfer Service to disable it.