View Full Version : FTP issues with Server 2k3 Small Business

11-20-2007, 10:51 PM
Internet>Dlink Router>24 port Switch> Server2k3

* = : <---cant post urls yet =)

Have a business that has server 2k3 small business running two web pages and ftp site on iis. both web pages are visible from internet and intranet. the ftp is only accessible from the server itself using ftp*//localhost or ftp*//
When it connect on the server it asks for user and pass like it should but its Its not accessible from inside or outside the network.
router is forwding port 20 and 21 to server IP above.
when I try to connect from either the lan or internet I get the same error. "Connection Closed by remote Host" thats using command line and filezilla. I even tried turning off the IIS FTP and stopping the FTP service and installing Filezilla server and tried again. same message. I don't believe that it is a DNS issue because I can type in the domain name or the public ip address and it returns the Error. Is there something or some service im not aware of between the router and the server that im am missing?

Im a newb when it comes to Server, but I'm learning quick =)

11-21-2007, 02:10 PM
I can connect on port 20 from anywhere, Lan or Internet. So, what else on the server box could be tying up port 21? Any Ideas?

11-21-2007, 04:42 PM
I don't use Windows Server much - but since it works from localhost but not remotely, that means it's not the FTP server that's the problem. FTP to Localhost still connects through the network to port 21, after all.

I suspect you've got an access restriction - the Windows equivalent of a "listen" statement where you need "listen *"

And if you've removed IIS FTP, installed Filezilla, and had the same problem, that cinches it, in my mind: Server itself is preventing external connections on that port. Check your security settings.

And, really, change the port. Run FTP on port 3001 or something, see if that makes any difference. Whether or not that works, the result tells you something.

11-22-2007, 12:41 PM
have you amended thefirewall exception list for ftp.exe ?

here is something I try to narrow down any ftp problems.

try to connect to ftp.microsoft.com
username: ftp
password: ftp

that would let you logged on as anonymous user, then try to find a file and
download it, this is to test if you can successfully download files from
other ftp server. if it can, then your w2k3 is working fine for ftp

11-28-2007, 02:21 AM
@ JohnR,

I am having an issue as well. I'm thinking what you've suggested might be a possible solution, but what exactly security settings should I check? Internet Options are all default and I have not messed with Group Policy or anything like that.

I'm running 2k3 Enterprise. It's soo weird I can log in via command line, but using FF or IE locally or externally I cannot log in with the windows firewall enabled.

I clearly have port 21 open on the firewall with no 3rd. party firewalls installed. I also do have FTP server enabled on the nic adapter that's hosting FTP.

I keep getting 425 error and i've read about every MS article online with no success. Using Passive FTP via IIS.

I do plan on using a different port for FTP, but im sooo determined to know exactly what is stopping me now from accessing it with everything default when it worked just fine before.

11-28-2007, 03:25 AM
Here's the thing I ran into, the last time I used 2003
(2003 Small Business, for the record).

By default, IIS was set to block execution of things like ASP and network access to programs. That took me *forever* to find out and fix.

I cannot log in with the windows firewall enabled.

But if you disable Windows Firewall, it works?

If so, the problem is Windows Firewall, full stop. Find a way to enable it to let FTP through, or disable it.

If disabling Windows Firewall *doesn't* stop the problem, start over in your IIS settings and go through the problem, step by step, until you find the access control settings. They *have* to be there.

I'm sorry I really can't give you more help. I simply don't deal with Server 2003 enough to do more than troubleshoot what the problem is. I can't give you directions on a solution.

11-30-2007, 03:26 PM
Yep that is true. If windows firewall is disabled it will let me connect just fine, but it was working with the firewall enabled just fine before. :confused: I'm gonna set it to a different port anyway im just determined to fix this issue.