View Full Version : Unable to Connect to Server in Remote Web Workplace

jay c
02-16-2010, 09:30 PM
One of my clients uses RWW to access servers at their main office. At a remote site, one computer can log into RWW and then remote desktop to any server with no problem. Another computer at that same site cannot. There is no error message. When you click on the Connect button IE opens a page with the Remote Web Workplace header, links for Log Off and Main Menu and nothing else. Just a white box where the remote desktop should be. Both computers are running Windows 7 w/ IE8 and MSSE.

I've checked things like pop-up blocking and trusted sites. Any ideas what else I should check?

02-17-2010, 12:38 AM
Is there a requirement for some software like java or something? Maybe reinstall these if there is.

Also, if it downloads an add-on, remove it and then go to the site again to redownload it.

jay c
02-17-2010, 01:10 AM
I think the only thing RWW downloads is an activex control. The one that isn't working is only a couple of weeks old, so it's possible it doesn't have the latest java, flash, etc. I'll give that a shot. Thanks!

jay c
02-17-2010, 01:13 PM
That wasn't it. I installed the latest flash and java, ensured .Net was installed, placed the RWW site in the trusted domains and set the Trusted Sites security level to Low. No difference.

I did see one odd thing, though. On the computer that is working, if I selected the checkbox for sharing files between the remote and local computers, it had the exact same problem as the computer that doesn't work: blank white field where there should be a remote desktop window. Uncheck that box and it connects fine. The other computer doesn't work no matter which boxes are checked. :confused:

02-17-2010, 08:01 PM
Check the firewall maybe? There might be an exception for the activex control. I would still try deleting the activeX control and allowing it to redownload. We have to do this every so often at work for Track-IT (enterprise version of TS Man as far as i know) as it just stops working.

jay c
02-19-2010, 07:14 PM
both of these computers are behind the same hardware firewall and both are using the default Windows software firewall, so I don't think that's the problem. The ActiveX control is in a dll file in system32. It's not in C:\Windows\Downloaded Programs (contains only desktop.ini) or in IE's list of downloaded controls (contains only Sun Java add-ons). It only shows up in IE's add-ons when I'm actually on the page where you select which server to connect to. From there I can only enable or disable it. I can't delete it. I tried renaming the .dll file, and it looked like it was going to work. IE acted like it was downloading the control, but then it did it again, and then again. Next time I loaded the page, I had the same old nothing. Just a blank white field where the 'RDP' view should be. I tried re-registering the dll and got an error message. I haven't had time to investigate that yet.