PDA

View Full Version : Windows Firewall


thecoldone06
09-04-2007, 06:53 PM
Got a question about the Windows firewall in XP. I am trying to allow ftp (port 21) to my ftp server from a clients computer. He is on a DSL connection and not behind any other firewall except for his Windows firewall. When I disable his firewall he is able to access my server via ftp. However, when I enable the firewall he is unable to. I have allowed an exception for port 21 (ftp) and 20 (ftp-data) via tcp and udp and it still does not allow the ftp connection to establish. What am I missing?

rurbaniak
09-04-2007, 08:01 PM
What are you using as your FTP Server software?

Did you add the program as an exception under the firewall settings?

gunslinger
09-04-2007, 08:30 PM
What are you using as your FTP Server software?

Did you add the program as an exception under the firewall settings?



I think rurbaniak is right. Go to your windows firewall and add the FTP program to your trusted programs.

thecoldone06
09-04-2007, 08:31 PM
I'm using the command prompt. I tried adding the command prompt exe file to the exception list but that did not help.

rurbaniak
09-04-2007, 08:37 PM
I'm using the command prompt. I tried adding the command prompt exe file to the exception list but that did not help.

I believe that is only a client, not a server. You'll need a FTP server like built into IIS.

thecoldone06
09-04-2007, 08:45 PM
I'm sorry, i thought you meant add the ftp client to the exclusion list. My ftp server is a webserver located on an IBM AS/400. With the firewall turned off, the connection is allowed, with it on, it is not.

rurbaniak
09-04-2007, 09:00 PM
I'm sorry, i thought you meant add the ftp client to the exclusion list. My ftp server is a webserver located on an IBM AS/400. With the firewall turned off, the connection is allowed, with it on, it is not.

Oh, you mean its blocked on the Windows side, next time mention the AS/400, I was picturing Windows Machines here.

Try adding the ftp.exe from the windows/system32 directory.

thecoldone06
09-04-2007, 10:09 PM
That had no effect on the connection. :(

rurbaniak
09-04-2007, 10:27 PM
That had no effect on the connection. :(

In general I would recommend getting a hardware firewall and getting off the Windows Firewall. I've had issues with the Windows Firewall blocking Wireless connections, even though the person had a WEP Key, and SSID. Plus the we all know there are holes in Windows, the Windows Firewall is part of Windows, so by eliminating the Windows Firewall and going with Hardware, you have added a layer of protection. You could also go with another kind of software firewall.

thecoldone06
09-04-2007, 10:47 PM
In general I would recommend getting a hardware firewall and getting off the Windows Firewall. I've had issues with the Windows Firewall blocking Wireless connections, even though the person had a WEP Key, and SSID. Plus the we all know there are holes in Windows, the Windows Firewall is part of Windows, so by eliminating the Windows Firewall and going with Hardware, you have added a layer of protection. You could also go with another kind of software firewall.

I agree with you 100%. I unfortunately can't do that as my client is the one using the Windows firewall. There is no convincing this guy of doing anything different, he's just going to do what he think is best. Thanks for the suggestions. I'll let you know if i get it working! :)

onsitehelper
12-27-2007, 01:48 AM
Have you made sure the ports are open in ur router?

You can check this by going to www.canyouseeme.org and enter port 20 or 21.