PDA

View Full Version : Missing NTDLR, need help


gunslinger
09-03-2007, 04:59 PM
Ok guys I have a problem I have not seen before and I need help. A customer brought in an older p4 machine yesterday and said that he had loaned it out to a friend for a few months and his friend had installed linux because the xp was full of spyware/viruses. I booted up and sure enough I had the option to boot windows or mandrake. After a driver back up I reformated the master drive and rebooted from the windows CD ( before I go on I might need to mention this machine has two hard drives and 2 DVD drives) when I booted up from the cd I got an error that had lots of ones and zeros after the boot from cd statement then it said " NTDLR not found " I first thought it was my CD so i tried 2 others with the same result. I double checked to make sure my IDE cable was secure and that the drive was seen in the bios. Still got the same error. So i booted up from an acronis cd and checked the drives out, all seems right. I have gone so far as to remove one HDD and one DVD drive and make sure the remaining drives are set to master, I still get the same error. Am I overlooking something simple?

gunslinger
09-03-2007, 07:03 PM
Update: After formating both drives and resetting the CMOS the system still trys to boot linux.

Fretzen
09-03-2007, 08:23 PM
I've seen the same thing happening to computers that have windows installed on the first hard drive and linux on the second one. Linux installs a loader at the beggining of the first hard drive so when you boot it redirects it to the linux HD so it can manage what OS you want to load.

When you disconnect the second hard drive it may seem that you won't have any problem as you want to load with windows but that loader will seek for the second HD and if it doesn't find it it will show that error NTLDR with 1's and 0's.

Just plugging again the second hard drive should stop the problem. In your case I suposse that the loader in the first hard drive is still there even though you have formatted it. Try to wipe any partition in that disk and create it again to be sure that there is nothing left. Hope that works. If you still had windows installed I believe that a fdisk /mbr would have fix it but i'm not sure.

gunslinger
09-03-2007, 10:46 PM
OK, I pulled the second drive and installed a floppy drive, ran fdisk to format then created a new active partition. Then I went into the bios and set to boot from CD, when I boot up now I get a boot from cd prompt then a no OS found error.

darren1270
09-04-2007, 11:02 AM
Hi when using linux on a dual boot system.... Linux replaces the MBR with Grub... all you need to do is to use a windows xp cd and boot from the cd and let it go through like your going to reinstall windows...you want to recover windows...... at the promt just type c:\fixmbr.... and that will re-write the boot record for windows....then when you reboot, windows will see the new mbr and your good to go.

ooops I should have read fretzen's post to the end...LOL

Fretzen
09-04-2007, 11:53 AM
As Darren says it seems that you still have that Grub loader in your hard drive. It's been a long time since I last used fdisk to make or delete partitions but I remember that some fdisk versions had trouble deleting partitions made with newer versions. For example, many times fdisk that came with W98 SE didn't delete a partition made with the fdisk that came with WMe.

Try fixing the master boot record as Darren says or using another software for partitioning. You can connect that drive on another computer with XP and use the built in disk administration tool, you can also use partition magic or you can just use the XP installation CD and use the menu where you set up the partitions for the installation.

On the other side, reading again your last post, if you're are booting from CD you shouldn't receive a no OS error, you should just boot from that CD whatever it is in it (UBCD, Windows installation, Ubuntu, etc). It's independent of what you have in your hard drive. It seems the computer is not really booting from CD and then it's trying again to boot from the HD. Check BIOS settings, the CD or even the drive to see what is not working.

gunslinger
09-04-2007, 01:07 PM
It makes no sense, the system will boot from an acronis CD but not a windows CD, and I know its not the disk because I have tried 3 and I just used two of them last week. I booted up acronis and wiped out the drive. Went to the bios and made sure all was right, inserted the windows CD and rebooted. Now it says " boot from cd " and just sits there no mater what I do, it just locks up.

darren1270
09-04-2007, 02:38 PM
This may be of no help but.... I would boot from a live cd such as ubuntu....copy all data that you need and use killdisk and start all over....for as long as you have tried to fix might be easier to reinstall?? Just my 2 cents worth but that is crazy that it will boot from one cd but not windows.

Fretzen
09-04-2007, 04:40 PM
Maybe the Windows CD makes some checks in the HD when it boots and as it founds something strange is hanging up. Just guessing. Anyway it seems that you still have something remaining in that hard drive. If you are sure that Windows CD and the CD drive are ok then it's the only thing I can think of.

Don't know if killdisk will wipe everything (never seen that application) but you should try something to be sure that the HD is completely clean. A fast thing you can try is to remove that HD and plug in a new one to see if the same thing happens. If with the new drive the Windows CD boots then you know it's fault of the first HD.

A low level format should erase everything in the disk but I don't know how to do it. Some time ago you could do it through the BIOS but now I suppose there should be some application that does the work.

Fretzen
09-04-2007, 04:48 PM
On the other hand it wouldn't be the first time a worn out CD drive can read perfectly a CD but has trouble reading a different one. Try with another CD drive if you can and everything else fails.

greggh
09-04-2007, 05:04 PM
It will boot from an Acronis cd because acronis is linux based...

gunslinger
09-04-2007, 06:03 PM
Ok , i'm going to try and run boot & nuke to compleatly wipe the drive, then try the windows cd again and see what happens.

darren1270
09-05-2007, 07:23 AM
Don't know if killdisk will wipe everything (never seen that application)

Killdisk has done a good job for me when I needed to use it... the free version only supports one pass but usually that's all it takes.

http://www.killdisk.com/downloadfree.htm

Good Luck,

Darren

Fretzen
09-05-2007, 08:15 AM
It seems a nice application darren1270. Some of the features of KillDisk taken from their webpage:


Detects and displays information about all partitions, hard disks and floppy drives currently connected to your computer
Erases partitions, logical drives and even not used disk space
File systems (FAT, FAT32, NTFS, etc) on the drive do not matter, detected physical drive is erased using low-level disk access


Gunslinger, it really seems this app could help you. I also read about Boot & Nuke and at least on the features list it doesn't say that it deletes partitions, it seems it only erases data. Maybe I'm wrong but couldn't find it. Give KillDisk a try if you still have the problem.

tkrabec
09-05-2007, 03:47 PM
FYI the only Current DoD compliant disk wipe is to make the disk into a nice fine powder.

gunslinger
09-05-2007, 05:46 PM
Here is what happend: I got up this morning about ready to take a hammer to the stupid thing. Figured I would try it one last time. Booted right up with the xp cd. Installed windows just fine. I still have no clue what was going on with this system.

going to install the other DVD burner and the other HDD one at a time and see what happens.

thecoldone06
09-05-2007, 05:48 PM
It is afraid of you. It was playing with you until you started to break out the hammer. It then said it had better shape up or it was going to get hit. haha. Glad it worked for ya.

gunslinger
09-05-2007, 05:57 PM
Now I get to play with driver issues, joy

Fretzen
09-05-2007, 09:22 PM
That's why I hate computers! :)