PDA

View Full Version : Keyboard Driver Issue


AnotherTechGuy
07-10-2007, 07:08 PM
Hello guys like I would just pop on and rack your brains abit.
Got this Dell Latitude C610 touchpad and external mouse works great but just as I press one key on the keyboard it locks up and will not work.
I can boot into the BIOS and the keyboard will work flawlessly but in windows XP nothing. Device Manager shows other device as Unknown Keyboard. I have tried all the drivers I could get from Dell and I can't get this Laptop on the net because it locks up before I can st the Network info.

So there is agood one to rack you brains on any help will be rewarded with the reputation system of this Forum

Bryce W
07-10-2007, 08:09 PM
As you have spotted yourself, this is most likely a driver issue. However, it might be worth checking in device manager what its actually complaining about. Having a question mark or exclaimation mark next to it does usually mean there isnt a driver for it, but it can also mean that the device is in an error state (even with the correct driver). See if it says anything else like saying its faulty rather than just missing a driver.

When you installed the seemingly correct drivers, what would it do? would they install fine but never fix anything? or would the system say that it couldnt find the correct driver in the files you provided?

AnotherTechGuy
07-15-2007, 04:48 AM
Well no luck on finding drivers so I ordered a Dell Driver CD for the Latitude laptop should get that this coming week,

Thanks for this input and help with this Knuckles10.

idiot_savant
07-17-2007, 06:12 PM
well I don't know if this would work....but it worked on my driver problem...though I got the right drivers for the device but still it won't install....what I did is installed a WinXP SP2...after installation all driver issues are gone. hope this works

AnotherTechGuy
07-21-2007, 01:17 PM
well I don't know if this would work....but it worked on my driver problem...though I got the right drivers for the device but still it won't install....what I did is installed a WinXP SP2...after installation all driver issues are gone. hope this works

Thanks I forgot all about that